On Mon, Aug 14, 2023 at 05:20:40PM +0200, Greg KH wrote: > On Mon, Aug 14, 2023 at 06:32:01PM +0530, Pavan Bobba wrote: > > On Sat, Aug 12, 2023 at 08:41:51PM +0200, Julia Lawall wrote: > > > > > > > > > On Sat, 12 Aug 2023, Pavan Bobba wrote: > > > > > > > On Fri, Aug 11, 2023 at 11:27:10PM +0200, Greg KH wrote: > > > > > On Wed, Aug 09, 2023 at 06:17:22PM +0530, Pavan Bobba wrote: > > > > > > Replace array name of camel case by snake case. Issue found > > > > > > by checkpatch > > > > > > > > > > > > Signed-off-by: Pavan Bobba <opensource206@xxxxxxxxx> > > > > > > --- > > > > > > v1 -> v2: 1. array name renamed from byVT3253B0_RFMD to by_vt3253b0_rfmd > > > > > > 2. typo in the subject line "small case" corrected with the > > > > > > proper word "snake case" > > > > > > > > > > > > Signed-off-by: Pavan Bobba <opensource206@xxxxxxxxx> > > > > > > --- > > > > > > drivers/staging/vt6655/baseband.c | 6 +++--- > > > > > > 1 file changed, 3 insertions(+), 3 deletions(-) > > > > > > > > > > > > diff --git a/drivers/staging/vt6655/baseband.c b/drivers/staging/vt6655/baseband.c > > > > > > index 0e135af8316b..cc8793256661 100644 > > > > > > --- a/drivers/staging/vt6655/baseband.c > > > > > > +++ b/drivers/staging/vt6655/baseband.c > > > > > > @@ -499,7 +499,7 @@ static const unsigned char by_vt3253_init_tab_rfmd[CB_VT3253_INIT_FOR_RFMD][2] = > > > > > > }; > > > > > > > > > > > > #define CB_VT3253B0_INIT_FOR_RFMD 256 > > > > > > -static const unsigned char byVT3253B0_RFMD[CB_VT3253B0_INIT_FOR_RFMD][2] = { > > > > > > +static const unsigned char by_vt3253b0_rfmd[CB_VT3253B0_INIT_FOR_RFMD][2] = { > > > > > > > > > > Again, the "by" needs to just be dropped. > > > > > > > > > > thanks, > > > > > > > > > > greg k-h > > > > > > > > hi greg...did'nt get your comment. can you please provide more elaborate > > > > info? > > > > > > Drop the letter "by_" at the beginning of the function name. It is there > > > ot indicate the type, which isn't done in the kernel. > > > > > > julia > > > > this is'nt a function name but an array name. is in't it fine? > > > > Not at all. The issue is the name, why are you just adding a "_" here? > What does "by" mean? (hint, this is a rhetorical question, I know, I > need you to figure it out so you know how to properly rename the > variable here...) > > thanks, > > greg k-h Thank you for the info. i have updated the patchset V3 based on this discussion and will keep this point for future patchsets