On ٢١/٣/٢٠٢٣ ١٧:٤٧, Uwe Kleine-König wrote:
Hello,
just some nitpicks:
On Tue, Mar 21, 2023 at 01:04:33AM +0200, Menna Mahmoud wrote:
Convert `to_gbphy_dev` and `to_gbphy_driver` macros into a
static inline function.
it is not great to have macro that use `container_of` macro,
s/it/It/; s/macro/macros/; s/use/use the/;
Okay, I will fix it.
because from looking at the definition one cannot tell what type
it applies to.
[...]
-#define to_gbphy_dev(d) container_of(d, struct gbphy_device, dev)
+static inline struct gbphy_device *to_gbphy_dev(const struct device *d)
drivers/staging/greybus/gbphy.c always passes a variable named
"dev" to this macro. So I'd call the parameter "dev", too, instead of
"d". This is also a more typical name for variables of that type.
+{
+ return container_of(d, struct gbphy_device, dev);
+}
[...]
};
-#define to_gbphy_driver(d) container_of(d, struct gbphy_driver, driver)
+static inline struct gbphy_driver *to_gbphy_driver(struct device_driver *d)
+{
+ return container_of(d, struct gbphy_driver, driver);
+}
With a similar reasoning (and also to not have "d"s that are either
device or device_driver) I'd recommend "drv" here.
please check this with Julia, because she said they should different.
Thanks,
Menna
Best regards
Uwe