Re: [PATCH] staging: vt6655: change the function name s_vGenerateTxParameter

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Thu, Nov 03, 2022 at 11:29:06AM +0000, Tanjuate Brunostar wrote:
> Remove the use of Hongarian notation which is not used in Linux kernel.
> Join some lines of code to avoid a line ending in a '('
> Reported by Checkpatch
> 
> Signed-off-by: Tanjuate Brunostar <tanjubrunostar0@xxxxxxxxx>
> ---
>  drivers/staging/vt6655/rxtx.c | 54 ++++++++++++++++-------------------
>  1 file changed, 25 insertions(+), 29 deletions(-)
> 
> diff --git a/drivers/staging/vt6655/rxtx.c b/drivers/staging/vt6655/rxtx.c
> index debc5d5daede..793a63b2ff46 100644
> --- a/drivers/staging/vt6655/rxtx.c
> +++ b/drivers/staging/vt6655/rxtx.c
> @@ -10,7 +10,7 @@
>   * Date: May 20, 2003
>   *
>   * Functions:
> - *      s_vGenerateTxParameter - Generate tx dma required parameter.
> + *      generate_tx_parameter - Generate tx dma required parameter.
>   *      vGenerateMACHeader - Translate 802.3 to 802.11 header
>   *      cbGetFragCount - Calculate fragment number count
>   *      csBeacon_xmit - beacon tx function
> @@ -95,17 +95,17 @@ static void fill_rts_header(struct vnt_private *pDevice,
>  			    unsigned short wCurrentRate,
>  			    unsigned char byFBOption);
>  
> -static void s_vGenerateTxParameter(struct vnt_private *pDevice,
> -				   unsigned char byPktType,
> -				   struct vnt_tx_fifo_head *,
> -				   void *pvRrvTime,
> -				   void *pvRTS,
> -				   void *pvCTS,
> -				   unsigned int	cbFrameSize,
> -				   bool bNeedACK,
> -				   unsigned int	uDMAIdx,
> -				   void *psEthHeader,
> -				   unsigned short wCurrentRate);
> +static void generate_tx_parameter(struct vnt_private *pDevice,
> +				  unsigned char byPktType,
> +				  struct vnt_tx_fifo_head *,
> +				  void *pvRrvTime,
> +				  void *pvRTS,
> +				  void *pvCTS,
> +				  unsigned int	cbFrameSize,
> +				  bool bNeedACK,
> +				  unsigned int	uDMAIdx,
> +				  void *psEthHeader,
> +				  unsigned short wCurrentRate);
>  

This function prototype is not needed at all, right?  So just delete it
instead of renaming it.

thanks,

greg k-h




[Index of Archives]     [Linux Driver Development]     [Linux Driver Backports]     [DMA Engine]     [Linux GPIO]     [Linux SPI]     [Video for Linux]     [Linux USB Devel]     [Linux Coverity]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [Yosemite Backpacking]
  Powered by Linux