On Wed, 26 Oct 2022, Emily Peri wrote: > Ternary statements that pick the min of two values can be replaced by > the built-in min() function. This improves readability, since its quicker > to understand min(x, y) than x < y ? x : y. Issue found by coccicheck. It looks like a nice change, but I get a compiler error afer the patch, julia > > Signed-off-by: Emily Peri <eperi1024@xxxxxxxxx> > --- > drivers/staging/rtl8723bs/os_dep/ioctl_cfg80211.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/drivers/staging/rtl8723bs/os_dep/ioctl_cfg80211.c b/drivers/staging/rtl8723bs/os_dep/ioctl_cfg80211.c > index 6aeb169c6ebf..0cf7d9f82b83 100644 > --- a/drivers/staging/rtl8723bs/os_dep/ioctl_cfg80211.c > +++ b/drivers/staging/rtl8723bs/os_dep/ioctl_cfg80211.c > @@ -1551,7 +1551,7 @@ static int rtw_cfg80211_set_wpa_ie(struct adapter *padapter, u8 *pie, size_t iel > > wps_ie = rtw_get_wps_ie(buf, ielen, NULL, &wps_ielen); > if (wps_ie && wps_ielen > 0) { > - padapter->securitypriv.wps_ie_len = wps_ielen < MAX_WPS_IE_LEN ? wps_ielen : MAX_WPS_IE_LEN; > + padapter->securitypriv.wps_ie_len = min(wps_ielen, MAX_WPS_IE_LEN); > memcpy(padapter->securitypriv.wps_ie, wps_ie, padapter->securitypriv.wps_ie_len); > set_fwstate(&padapter->mlmepriv, WIFI_UNDER_WPS); > } else { > -- > 2.34.1 > > >