On 21-10-2022 14:55, Tanjuate Brunostar wrote: > Code style warnings reported by checkpatch. > Improve the layout of a function header: > Put the first parameter immediately after the '(' and align the other > parameters underneath it. > > Signed-off-by: Tanjuate Brunostar <tanjubrunostar0@xxxxxxxxx> > > --- > v2: put static and void on the same line and adjusted the indentation as > suggested by Greg KH > --- > v3: Reformat the code by inserting tabs and white space as recommended > by Nam Cao and Julia Lawall > --- > v4: final version of this patch > > drivers/staging/vt6655/rxtx.c | 78 +++++++++++++++-------------------- > 1 file changed, 33 insertions(+), 45 deletions(-) > > diff --git a/drivers/staging/vt6655/rxtx.c b/drivers/staging/vt6655/rxtx.c > index 5bdb5176772c..1e5036121665 100644 > --- a/drivers/staging/vt6655/rxtx.c > +++ b/drivers/staging/vt6655/rxtx.c > @@ -85,35 +85,27 @@ static const unsigned short wFB_Opt1[2][5] = { > #define DATADUR_A_F1 13 > > /*--------------------- Static Functions --------------------------*/ > -static > -void > -s_vFillRTSHead( > - struct vnt_private *pDevice, > - unsigned char byPktType, > - void *pvRTS, > - unsigned int cbFrameLength, > - bool bNeedAck, > - bool bDisCRC, > - struct ieee80211_hdr *hdr, > - unsigned short wCurrentRate, > - unsigned char byFBOption > -); > - > -static > -void > -s_vGenerateTxParameter( > - struct vnt_private *pDevice, > - unsigned char byPktType, > - struct vnt_tx_fifo_head *, > - void *pvRrvTime, > - void *pvRTS, > - void *pvCTS, > - unsigned int cbFrameSize, > - bool bNeedACK, > - unsigned int uDMAIdx, > - void *psEthHeader, > - unsigned short wCurrentRate > -); > +static void s_vFillRTSHead(struct vnt_private *pDevice, > + unsigned char byPktType, > + void *pvRTS, > + unsigned int cbFrameLength, > + bool bNeedAck, > + bool bDisCRC, > + struct ieee80211_hdr *hdr, > + unsigned short wCurrentRate, > + unsigned char byFBOption); > + > +static void s_vGenerateTxParameter(struct vnt_private *pDevice, > + unsigned char byPktType, > + struct vnt_tx_fifo_head *, > + void *pvRrvTime, > + void *pvRTS, > + void *pvCTS, > + unsigned int cbFrameSize, > + bool bNeedACK, > + unsigned int uDMAIdx, > + void *psEthHeader, > + unsigned short wCurrentRate); > > static unsigned int > s_cbFillTxBufHead(struct vnt_private *pDevice, unsigned char byPktType, > @@ -121,22 +113,18 @@ s_cbFillTxBufHead(struct vnt_private *pDevice, unsigned char byPktType, > unsigned int uDMAIdx, struct vnt_tx_desc *pHeadTD, > unsigned int uNodeIndex); > > -static > -__le16 > -s_uFillDataHead( > - struct vnt_private *pDevice, > - unsigned char byPktType, > - void *pTxDataHead, > - unsigned int cbFrameLength, > - unsigned int uDMAIdx, > - bool bNeedAck, > - unsigned int uFragIdx, > - unsigned int cbLastFragmentSize, > - unsigned int uMACfragNum, > - unsigned char byFBOption, > - unsigned short wCurrentRate, > - bool is_pspoll > -); > +static __le16 s_uFillDataHead(struct vnt_private *pDevice, > + unsigned char byPktType, > + void *pTxDataHead, > + unsigned int cbFrameLength, > + unsigned int uDMAIdx, > + bool bNeedAck, > + unsigned int uFragIdx, > + unsigned int cbLastFragmentSize, > + unsigned int uMACfragNum, > + unsigned char byFBOption, > + unsigned short wCurrentRate, > + bool is_pspoll); > > /*--------------------- Export Variables --------------------------*/ > Can we also work upon the naming convention from pDevice -> p_device and other places if that make sense here. Regards, ~Praveen.