Re: [PATCH v3 05/10] staging: r8188eu: correct misspelled words in comments

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 




On Thu, 20 Oct 2022, Deepak R Varma wrote:

> Incorrectly spelled words should be corrected as per the Linux
> coding-style guidelines.

This seems a bit verbose.  I think that spelling mistakes should just be
fixed, and the need for fixes shouldn't have to rely on style guidelines.

Fix spelling mistakes in code comments across the driver.

> @@ -4615,7 +4615,7 @@ int issue_probereq_ex(struct adapter *padapter, struct ndis_802_11_ssid *pssid,
>  	return ret;
>  }
>
> -/*  if psta == NULL, indiate we are station(client) now... */
> +/*  if psta == NULL, indicate we are station(client) now... */

Does station plat the role of a function call?  If (client) is just giving
some extra information there should eb a space before the (.

>  void issue_auth(struct adapter *padapter, struct sta_info *psta, unsigned short status)
>  {
>  	struct xmit_frame *pmgntframe;
> @@ -5014,7 +5014,7 @@ void issue_assocreq(struct adapter *padapter)
>  				if (!padapter->registrypriv.wifi_spec) {
>  					/* Commented by Kurt 20110629 */
>  					/* In some older APs, WPS handshake */
> -					/* would be fail if we append vender extensions informations to AP */
> +					/* would be fail if we append vender extensions information to AP */

envder -> vendor
extensions -> extension

> @@ -5344,7 +5344,7 @@ static int _issue_qos_nulldata(struct adapter *padapter, unsigned char *da, u16
>  	return ret;
>  }
>
> -/* when wait_ms > 0 , this function shoule be called at process context */
> +/* when wait_ms > 0 , this function should be called at process context */

Unnecessary space before the comma.

> @@ -6058,7 +6058,7 @@ void site_survey(struct adapter *padapter)
>  		} else {
>  			/*  20100721:Interrupt scan operation here. */
>  			/*  For SW antenna diversity before link, it needs to switch to another antenna and scan again. */
> -			/*  It compares the scan result and select beter one to do connection. */
> +			/*  It compares the scan result and select better one to do connection. */

select -> selects a

> +++ b/drivers/staging/r8188eu/hal/rtl8188e_phycfg.c
> @@ -94,7 +94,7 @@ void rtl8188e_PHY_SetBBReg(struct adapter *Adapter, u32 RegAddr, u32 BitMask, u3
>  /**
>  * Function:	phy_RFSerialRead
>  *
> -* OverView:	Read regster from RF chips
> +* OverView:	Read register from RF chips

Not sure why View is capitalized.

julia




[Index of Archives]     [Linux Driver Development]     [Linux Driver Backports]     [DMA Engine]     [Linux GPIO]     [Linux SPI]     [Video for Linux]     [Linux USB Devel]     [Linux Coverity]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [Yosemite Backpacking]
  Powered by Linux