On 10/17/22 17:56, Deepak R Varma wrote:
Address different kinds of checkpatch complains for the staging/r8188eu module. The patches are required to be applied in sequence. Changes in v1: 1. Improve language / grammar for the patch descriptions 2. Further improve code reformatting Deepak R Varma (4): staging: r8188eu: use Linux kernel variable naming convention staging: r8188eu: reformat long computation lines staging: r8188eu: remove {} for single statement blocks staging: r8188eu: use htons macro instead of __constant_htons drivers/staging/r8188eu/core/rtw_br_ext.c | 122 +++++++++++----------- 1 file changed, 62 insertions(+), 60 deletions(-) -- 2.30.2
I think this patch series should be v2 as the first one was a v1. The next one should be the v3.
Please do variable changes driver wide and not only limited to a file. Example: This line contains the old variable: void *scdb_findEntry(struct adapter *priv, unsigned char *ipAddr); But in this line you have already changed ip_addr. void *scdb_findEntry(struct adapter *priv, unsigned char *ip_addr) { unsigned char network_addr[MAX_NETWORK_ADDR_LEN]; struct nat25_network_db_entry *db; int hash; ... Please change all networkAddr and not only some. Is it possible to changing __constant_htons as well in the entire driver? Driver can be applied and compiled. Tested device. Thanks Bye Philipp