On Mon, Apr 25, 2022 at 11:25:32PM +0530, Vihas Makwana wrote: > On Mon, Apr 25, 2022 at 12:30 AM Pavel Skripkin <paskripkin@xxxxxxxxx> wrote: > > > > Hi Vihas, > > > > On 4/24/22 19:31, Vihas Makwana wrote: > > > There's a NULL check on pmlmepriv in rtw_mlme.c:112 which makes no sense > > > as rtw_free_mlme_priv_ie_data() dereferences it unconditionally and it > > > would have already crashed at this point. > > > Fix this by moving rtw_free_mlme_priv_ie_data() inside the check. > > > > > > Signed-off-by: Vihas Makwana <makvihas@xxxxxxxxx> > > > > That's good catch, but looks like the check is just redundant > > > > This function is called only from it's wrapper called > > rtw_free_mlme_priv() and rtw_free_mlme_priv() is called from 2 places: > > > > 4 drivers/staging/r8188eu/os_dep/os_intfs.c|531 col 2| > > rtw_free_mlme_priv(&padapter->mlmepriv); > > 5 drivers/staging/r8188eu/os_dep/os_intfs.c|579 col 2| > > rtw_free_mlme_priv(&padapter->mlmepriv); > > > > _Very_ unlikely that `&padapter->mlmepriv` expression will become NULL. > > > So I guess either we should remove the check or mark it with the > `unlikely()` macro. The likely/unlikely() macros are only for when you can prove it makes a difference to benchmark. They hurt readability, but they're important for optimizing the fast path. Just remove the check. regards, dan carpenter