On Fri, Apr 08, 2022 at 06:15:14AM +0200, Julia Lawall wrote: > On Thu, 7 Apr 2022, Rebecca Mckeever wrote: > > > Replace ternary statement with an if statement followed by an assignment > > to increase readability and make error handling more obvious. > > Found with minmax coccinelle script. > > > > Signed-off-by: Rebecca Mckeever <remckee0@xxxxxxxxx> > > --- > > drivers/staging/rtl8192u/ieee80211/ieee80211_wx.c | 4 +++- > > 1 file changed, 3 insertions(+), 1 deletion(-) > > > > diff --git a/drivers/staging/rtl8192u/ieee80211/ieee80211_wx.c b/drivers/staging/rtl8192u/ieee80211/ieee80211_wx.c > > index 78cc8f357bbc..9885917b9199 100644 > > --- a/drivers/staging/rtl8192u/ieee80211/ieee80211_wx.c > > +++ b/drivers/staging/rtl8192u/ieee80211/ieee80211_wx.c > > @@ -470,7 +470,9 @@ int ieee80211_wx_get_encode(struct ieee80211_device *ieee, > > return 0; > > } > > len = crypt->ops->get_key(keybuf, SCM_KEY_LEN, NULL, crypt->priv); > > - erq->length = (len >= 0 ? len : 0); > > + if (len < 0) > > + len = 0; > > + erq->length = len; > > Maybe you could use max here? Initially Rebecca did use max() but I NAKed it. It's really not less readable. Better to handle the error explicitly. Keep the error path indented two tabs. Separate from the success path. regards, dan carpenter