On Sun, 2022-02-06 at 09:17 -0800, Joe Perches wrote: > On Sun, 2022-02-06 at 14:16 +0000, David Laight wrote: > > From: joelcchangg@xxxxxxxxx > > > Sent: 06 February 2022 07:46 [] > This _might_ be better with the return type on a separate line > > Something like: > > static struct cvmx_usb_transaction * > cvmx_usb_submit_transaction(struct octeon_hcd *usb, struct cvmx_usb_pipe *pipe, > enum cvmx_usb_transfer type, > u64 buffer, int buffer_length, > u64 control_header, int iso_start_frame, > int iso_number_packets, > struct cvmx_usb_iso_packet *iso_packets, > struct urb *urb) As this is a static function only used by this compilation unit, it's maybe even better removing the unnecessary cvmx_usb_ prefix too. Maybe a bunch of unnecessary prefix removals...