On Wed, Jan 05, 2022 at 05:35:47PM -0300, Gaston Gonzalez wrote: > In the kernel, all names related to the chip BCM2835 are always named > bcm2835_*. To avoid confusion, and to make things more consistent, > rename the macros BM2835_MMAL_VERSION and BM2835_MMAL_MODULE_NAME > accordingly. > > While at it, some realignments were made to improve readability. > > Suggested-by: Stefan Wahren <stefan.wahren@xxxxxxxx> > Signed-off-by: Gaston Gonzalez <gascoar@xxxxxxxxx> > --- > .../vc04_services/bcm2835-camera/bcm2835-camera.c | 14 ++++++-------- > 1 file changed, 6 insertions(+), 8 deletions(-) > > diff --git a/drivers/staging/vc04_services/bcm2835-camera/bcm2835-camera.c b/drivers/staging/vc04_services/bcm2835-camera/bcm2835-camera.c > index aaf529f2186c..c729b1b7de71 100644 > --- a/drivers/staging/vc04_services/bcm2835-camera/bcm2835-camera.c > +++ b/drivers/staging/vc04_services/bcm2835-camera/bcm2835-camera.c > @@ -33,8 +33,8 @@ > #include "mmal-parameters.h" > #include "bcm2835-camera.h" > > -#define BM2835_MMAL_VERSION "0.0.2" > -#define BM2835_MMAL_MODULE_NAME "bcm2835-v4l2" > +#define BCM2835_MMAL_VERSION "0.0.2" MODULE_VERSION means nothing when the code is in the kernel tree, this shold just be removed entirely. > +#define BCM2835_MMAL_MODULE_NAME "bcm2835-v4l2" KBUILD_MODULE_NAME provides this, please delete this and just use that instead. This can be 2 different commits because of this. thanks, greg k-h