On Tue, Aug 3, 2021 at 3:36 PM Nathan Chancellor <nathan@xxxxxxxxxx> wrote: > > Clang warns: > > drivers/staging/r8188eu/hal/rtl8188e_rf6052.c:344:13: warning: > explicitly assigning value of variable of type 'u32' (aka 'unsigned > int') to itself [-Wself-assign] > writeVal = writeVal; > ~~~~~~~~ ^ ~~~~~~~~ > 1 warning generated. > > Remove this branch as it is useless. > > Signed-off-by: Nathan Chancellor <nathan@xxxxxxxxxx> > --- > drivers/staging/r8188eu/hal/rtl8188e_rf6052.c | 2 -- > 1 file changed, 2 deletions(-) > > diff --git a/drivers/staging/r8188eu/hal/rtl8188e_rf6052.c b/drivers/staging/r8188eu/hal/rtl8188e_rf6052.c > index 335b120ce603..77889dc05858 100644 > --- a/drivers/staging/r8188eu/hal/rtl8188e_rf6052.c > +++ b/drivers/staging/r8188eu/hal/rtl8188e_rf6052.c > @@ -340,8 +340,6 @@ static void get_rx_power_val_by_reg(struct adapter *Adapter, u8 Channel, > /* This mechanism is only applied when Driver-Highpower-Mechanism is OFF. */ > if (pdmpriv->DynamicTxHighPowerLvl == TxHighPwrLevel_BT1) > writeVal = writeVal - 0x06060606; > - else if (pdmpriv->DynamicTxHighPowerLvl == TxHighPwrLevel_BT2) > - writeVal = writeVal; Hopefully the author didn't mean to subtract another magic constant like they did above. This also eliminates the last use of TxHighPwrLevel_BT2, but it's probably ok to keep the define in drivers/staging/r8188eu/include/odm.h. Reviewed-by: Nick Desaulniers <ndesaulniers@xxxxxxxxxx> > *(pOutWriteVal+rf) = writeVal; > } > } > -- > 2.33.0.rc0 -- Thanks, ~Nick Desaulniers