This series mostly addresses the code readability. Additionally it contains a fix for a change from my last series. Stefan Wahren (16): staging: vchiq_core: fix logic in poll_services_of_group staging: vchiq_arm: introduce free_bulk_waiter staging: vchiq_core: move internals to C source staging: vchiq_core: get the rid of IS_POW2 staging: vchiq_core: get the rid of vchiq_static_assert staging: vchiq_core: put spaces around operators staging: vchiq_core: avoid precedence issues staging: vchiq_core: use define for message type shift staging: vchiq_core: introduce message specific make macros staging: vchiq_core: simplify WARN_ON conditions staging: vchiq_arm: tidy up service function naming staging: vchiq_core: introduce process_free_data_message staging: vchiq_core: reduce indentation in parse_open staging: vchiq_core: store message id in local variable staging: vchiq_connected: move EXPORT_SYMBOL below the right function staging: vchiq_core: introduce handle_poll .../vc04_services/interface/vchiq_arm/vchiq_arm.c | 71 ++- .../interface/vchiq_arm/vchiq_connected.c | 2 +- .../vc04_services/interface/vchiq_arm/vchiq_core.c | 606 ++++++++++++--------- .../vc04_services/interface/vchiq_arm/vchiq_core.h | 79 +-- 4 files changed, 375 insertions(+), 383 deletions(-) -- 2.7.4