On Tue, May 25, 2021 at 08:44:44AM +0200, Greg KH wrote: > On Mon, May 24, 2021 at 11:45:32PM +0100, Phillip Potter wrote: > > Remove the ASSERT and ODM_RT_ASSERT macros from include/odm_debug.h > > as they are unnecessary. > > > > ASSERT does nothing, compiling to a single empty statement. > > ODM_RT_ASSERT is used in only one place, in the ODM_RAStateCheck > > function with hal/odm.c - it seems to have been intended as an > > assertion of some kind, but given it is always called with false > > here, there is little point in it not just being a pr_info() call. > > > > Also, the lines relating to the file, function and line number are > > not needed as the pr_info() with the function name and error message > > is sufficient should anyone wish to track down this error at a source > > level, within what is currently a relatively small function. > > > > Signed-off-by: Phillip Potter <phil@xxxxxxxxxxxxxxxx> > > --- > > drivers/staging/rtl8188eu/hal/odm.c | 2 +- > > drivers/staging/rtl8188eu/include/odm_debug.h | 13 ------------- > > 2 files changed, 1 insertion(+), 14 deletions(-) > > > > diff --git a/drivers/staging/rtl8188eu/hal/odm.c b/drivers/staging/rtl8188eu/hal/odm.c > > index 4d659a812aed..b800d0c6dff5 100644 > > --- a/drivers/staging/rtl8188eu/hal/odm.c > > +++ b/drivers/staging/rtl8188eu/hal/odm.c > > @@ -824,7 +824,7 @@ bool ODM_RAStateCheck(struct odm_dm_struct *pDM_Odm, s32 RSSI, bool bForceUpdate > > LowRSSIThreshForRA += GoUpGap; > > break; > > default: > > - ODM_RT_ASSERT(pDM_Odm, false, ("wrong rssi level setting %d !", *pRATRState)); > > + pr_info("%s(): wrong rssi level setting %d!\n", __func__, *pRATRState); > > I know you're just copying what the existing code does, but this really > should just be a dev_err() call instead. It's not "info", and as this > is a driver, dev_*() should be called instead. > > So I'll take this one, but for future cleanups, consider changing the > pr_*() calls to the correct ones. > > thanks, > > greg k-h Dear Greg, Thank you for this, I will make sure to bear this in mind for the future. Regards, Phil