This series mostly addresses the code readability. Additionally it contains a follow-up patch for a change from my last series. Stefan Wahren (20): staging: vchiq_core: fix return type of vchiq_init_state staging: vchiq_core: drop unnecessary release_count staging: vchiq_core: separate postfix increment staging: vc04_services: remove __VCCOREVER__ staging: vchiq_arm: balance braces for if-else statements staging: vchiq_core: introduce poll_services_of_group staging: vchiq_core: avoid indention in poll_services_of_group staging: vchiq_arm: Use define for doorbell irq staging: vchiq_arm: drop ftrace-like logging staging: vchiq_arm: Prefer kzalloc(sizeof(*waiter)...) staging: vchiq_arm: drop non-beneficial comments staging: vchiq_arm: add blank line after declarations staging: vchiq_arm: re-arrange function header staging: vchiq_core: reduce indention in release_service_messages staging: vchiq_core: fix comment in vchiq_shutdown_internal staging: vchiq_arm: make vchiq_shutdown_internal return void staging: vchiq_arm: Avoid unnecessary line breaks staging: vchiq_core: introduce parse_message staging: vchiq_core: introduce defines for close_recvd staging: vchiq_core: introduce defines for retry_poll drivers/staging/vc04_services/Makefile | 2 +- .../interface/vchiq_arm/vchiq_2835_arm.c | 4 +- .../vc04_services/interface/vchiq_arm/vchiq_arm.c | 175 ++-- .../interface/vchiq_arm/vchiq_connected.h | 8 - .../vc04_services/interface/vchiq_arm/vchiq_core.c | 897 +++++++++++---------- .../vc04_services/interface/vchiq_arm/vchiq_core.h | 2 +- .../interface/vchiq_arm/vchiq_debugfs.c | 6 +- 7 files changed, 513 insertions(+), 581 deletions(-) -- 2.7.4