Simple, straightforward patches that were compiled tested. v4: - drop "spi: s3c64xx: use bitfield access macros" patch as there was no agreement on how the reg fields should be handled. - don't change the style in s3c64xx_spi_dt_match(), drop just the unneeded casts - collect Sam's R-b tags v3: - reworked the bitfied access macros patch so that the bit operations are the same as before the patch. Fix S3C64XX_SPI_PSR_MASK value, drop S3C64XX_SPI_CS_NSC_CNT_MASK. - add a new patches to explicitly remove a duplicated definition and to drop a superfluous bitwise NOT operation. - collect R-b tags v2: https://lore.kernel.org/linux-arm-kernel/36a664b1-666d-4fc4-90d9-35b42e56973d@xxxxxxxxxx/ Tudor Ambarus (16): spi: s3c64xx: explicitly include <linux/io.h> spi: s3c64xx: explicitly include <linux/bits.h> spi: s3c64xx: avoid possible negative array index spi: s3c64xx: fix typo, s/configuartion/configuration spi: s3c64xx: sort headers alphabetically spi: s3c64xx: remove unneeded (void *) casts in of_match_table spi: s3c64xx: remove else after return spi: s3c64xx: move common code outside if else spi: s3c64xx: check return code of dmaengine_slave_config() spi: s3c64xx: propagate the dma_submit_error() error code spi: s3c64xx: rename prepare_dma() to s3c64xx_prepare_dma() spi: s3c64xx: return ETIMEDOUT for wait_for_completion_timeout() spi: s3c64xx: drop blank line between declarations spi: s3c64xx: downgrade dev_warn to dev_dbg for optional dt props spi: s3c64xx: remove duplicated definition spi: s3c64xx: drop a superfluous bitwise NOT operation drivers/spi/spi-s3c64xx.c | 80 +++++++++++++++++++-------------------- 1 file changed, 40 insertions(+), 40 deletions(-) -- 2.43.0.594.gd9cf4e227d-goog