On Mon, Jun 21, 2021 at 1:40 PM Mark Brown <broonie@xxxxxxxxxx> wrote: > > On Sat, Jun 19, 2021 at 02:15:26PM +0300, Andy Shevchenko wrote: > > The boolean expression to get kmap_buf is hard to read due to > > too many unneeded parentheses. Remove them for good. > > > - const bool kmap_buf = ((unsigned long)buf >= PKMAP_BASE && > > - (unsigned long)buf < (PKMAP_BASE + > > - (LAST_PKMAP * PAGE_SIZE))); > > + const bool kmap_buf = (unsigned long)buf >= PKMAP_BASE && > > + (unsigned long)buf < (PKMAP_BASE + LAST_PKMAP * PAGE_SIZE); > > No, I think this makes things worse - to the extent there's an issue > here it's not excessive brackets. How? I can't see any issues here and dropping excessive brackets helps to read it better. For example, the exterior brackets do nothing except making it harder to read, i.e. the expression inside them is already type of boolean and I have no clue what they are for. -- With Best Regards, Andy Shevchenko