Hi Miquel On 5/27/21 6:23 PM, Miquel Raynal wrote: > Hi Patrice, > > + Pratyush > > <patrice.chotard@xxxxxxxxxxx> wrote on Thu, 27 May 2021 18:12:52 +0200: > >> From: Patrice Chotard <patrice.chotard@xxxxxxxxxxx> >> >> After power up, all SPI NAND's blocks are locked. Only read operations >> are allowed, write and erase operations are forbidden. >> The SPI NAND framework unlocks all the blocks during its initialization. >> >> During a standby low power, the memory is powered down, losing its >> configuration. >> During the resume, the QSPI driver state is restored but the SPI NAND >> framework does not reconfigured the memory. >> >> This patch adds SPI-NAND MTD PM handlers for resume ops. >> SPI NAND resume op re-initializes SPI NAND flash to its probed state. >> >> Signed-off-by: Christophe Kerello <christophe.kerello@xxxxxxxxxxx> >> Signed-off-by: Patrice Chotard <patrice.chotard@xxxxxxxxxxx> >> --- >> Changes in v3: >> - Add spinand_read_cfg() call to repopulate cache >> >> Changes in v2: >> - Add helper spinand_block_unlock(). >> - Add spinand_ecc_enable() call. >> - Remove some dev_err(). >> - Fix commit's title and message. >> >> drivers/mtd/nand/spi/core.c | 33 +++++++++++++++++++++++++++++++++ >> 1 file changed, 33 insertions(+) >> >> diff --git a/drivers/mtd/nand/spi/core.c b/drivers/mtd/nand/spi/core.c >> index 1f699ad84f1b..e3fcbcf381c3 100644 >> --- a/drivers/mtd/nand/spi/core.c >> +++ b/drivers/mtd/nand/spi/core.c >> @@ -1099,6 +1099,38 @@ static int spinand_block_unlock(struct spinand_device *spinand) >> return ret; >> } >> >> +static void spinand_mtd_resume(struct mtd_info *mtd) >> +{ >> + struct spinand_device *spinand = mtd_to_spinand(mtd); >> + int ret; >> + >> + ret = spinand_reset_op(spinand); >> + if (ret) >> + return; >> + >> + ret = spinand_read_cfg(spinand); >> + if (ret) >> + return; >> + >> + ret = spinand_init_quad_enable(spinand); >> + if (ret) >> + return; >> + >> + ret = spinand_upd_cfg(spinand, CFG_OTP_ENABLE, 0); >> + if (ret) >> + return; >> + >> + ret = spinand_manufacturer_init(spinand); >> + if (ret) >> + return; >> + >> + ret = spinand_block_unlock(spinand); >> + if (ret) >> + return; >> + >> + spinand_ecc_enable(spinand, false); >> +} > > Sorry for not being clear, but I think what Pratyush meant was that > you could create a helper doing all the common initializations between > spinand_init() and spinand_resume() and call it from these places to > avoid code duplication. His comment somehow outclassed mine as I only > focused on the unlock part (which I think is clearer anyway, please keep > it like that). > My bad too, i read too quickly Pratyush's asnwer. I am preparing a v4. Thanks Patrice >> + >> static int spinand_init(struct spinand_device *spinand) >> { >> struct device *dev = &spinand->spimem->spi->dev; >> @@ -1186,6 +1218,7 @@ static int spinand_init(struct spinand_device *spinand) >> mtd->_block_isreserved = spinand_mtd_block_isreserved; >> mtd->_erase = spinand_mtd_erase; >> mtd->_max_bad_blocks = nanddev_mtd_max_bad_blocks; >> + mtd->_resume = spinand_mtd_resume; >> >> if (nand->ecc.engine) { >> ret = mtd_ooblayout_count_freebytes(mtd); > > Thanks, > Miquèl >