Am 25.03.19 um 10:52 schrieb kernel@xxxxxxxxxxxxxxxx: >> On 25.03.2019, at 10:28, Stefan Wahren <stefan.wahren@xxxxxxxx> wrote: >> >> Hi Martin, >> >> Am 24.03.19 um 18:50 schrieb kernel@xxxxxxxxxxxxxxxx: >>> + >>> +#if defined(CONFIG_DEBUG_FS) >>> +#define BCM2835_AUX_INCR(field) ((field)++) >>> + u64 count_transfer_polling; >>> + u64 count_transfer_irq; >>> + u64 count_transfer_irq_after_poll; >>> + >>> + struct dentry *debugfs_dir; >>> +#else >>> +#define BCM2835_AUX_INCR(field) >>> +#endif /* CONFIG_DEBUG_FS */ >>> }; >>> >> is there a chance to avoid these ifdefs CONFIG_DEBUG_FS? >> > The idea was not to add those stats at all when debugfs is disabled. > Other groups (e.g net/can) prefer it this way… Yes, this is always a balance between size reduction and code readability. My biggest concern was about BCM2835_AUX_INCR