Re: [PATCH v3 08/13] spi: atmel-quadspi: drop unused and NOP transfer macros

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Sat, 2 Feb 2019 08:46:38 +0000
<Tudor.Ambarus@xxxxxxxxxxxxx> wrote:

> On 02/02/2019 09:13 AM, Boris Brezillon wrote:
> > On Sat, 2 Feb 2019 04:07:33 +0000
> > <Tudor.Ambarus@xxxxxxxxxxxxx> wrote:
> >   
> >> From: Tudor Ambarus <tudor.ambarus@xxxxxxxxxxxxx>
> >>
> >> Remove NOP when setting read transfer type. Remove useless
> >> setting of write transfer type when
> >> op->data.dir == SPI_MEM_DATA_IN && !op->data.nbytes.
> >>
> >> QSPI_IFR_TFRTYP_TRSFR_WRITE is specific just to sama5d2 qspi,
> >> rename it to QSPI_IFR_SAMA5D2_WRITE_TRSFR.
> >>
> >> Signed-off-by: Tudor Ambarus <tudor.ambarus@xxxxxxxxxxxxx>
> >> ---
> >> v3: new patch
> >>
> >>  drivers/spi/atmel-quadspi.c | 12 +++---------
> >>  1 file changed, 3 insertions(+), 9 deletions(-)
> >>
> >> diff --git a/drivers/spi/atmel-quadspi.c b/drivers/spi/atmel-quadspi.c
> >> index d26d4cd0e36b..bfa5f5e92d96 100644
> >> --- a/drivers/spi/atmel-quadspi.c
> >> +++ b/drivers/spi/atmel-quadspi.c
> >> @@ -113,11 +113,7 @@
> >>  #define QSPI_IFR_OPTL_4BIT              (2 << 8)
> >>  #define QSPI_IFR_OPTL_8BIT              (3 << 8)
> >>  #define QSPI_IFR_ADDRL                  BIT(10)
> >> -#define QSPI_IFR_TFRTYP_MASK            GENMASK(13, 12)
> >> -#define QSPI_IFR_TFRTYP_TRSFR_READ      (0 << 12)
> >> -#define QSPI_IFR_TFRTYP_TRSFR_READ_MEM  (1 << 12)
> >> -#define QSPI_IFR_TFRTYP_TRSFR_WRITE     (2 << 12)
> >> -#define QSPI_IFR_TFRTYP_TRSFR_WRITE_MEM (3 << 13)
> >> +#define QSPI_IFR_SAMA5D2_WRITE_TRSFR	BIT(13)  
> > 
> > Can you define QSPI_IFR_TFRTYP_MEM (bit 12) even if it's not used yet?  
> 
> Shouldn't be introduced with the dir map support?

I like when all regs/reg-fields are defined, even if they're not used.
In this case, you're cleary splitting the TFRTYP_TRSFR_ bitfields in 2:
one bit encoding the mem/reg transfer type and one bit encoding the
direction of the transfer (read/write). Just think it's better to add
bit 12 definition now.



[Index of Archives]     [Linux Kernel]     [Linux ARM (vger)]     [Linux ARM MSM]     [Linux Omap]     [Linux Arm]     [Linux Tegra]     [Fedora ARM]     [Linux for Samsung SOC]     [eCos]     [Linux Fastboot]     [Gcc Help]     [Git]     [DCCP]     [IETF Announce]     [Security]     [Linux MIPS]     [Yosemite Campsites]

  Powered by Linux