On Thu, Nov 10, 2016 at 05:49:15PM +0530, Sanchayan Maity wrote: A couple of small things, please send followup patches fixing them. > + rx_word = is_double_byte_mode(dspi); > + > + len = rx_word ? (dma->curr_xfer_len / 2) : dma->curr_xfer_len; Please use normal if statements, they're much easier to read. > +err_slave_config: > + devm_kfree(dev, dma->rx_dma_buf); > +err_rx_dma_buf: > + devm_kfree(dev, dma->tx_dma_buf); You really shouldn't need to explicitly free things like this if you're using devm_, especially in the error path from the probe function like this where a failure is just going to result in the device failing to instantiate so you won't have the allocation sitting around unused for any length of time.
Attachment:
signature.asc
Description: PGP signature