On Tue, 2016-04-12 at 02:30 +0100, Mark Brown wrote: > On Tue, Apr 05, 2016 at 08:45:28PM +0100, Ben Hutchings wrote: > > > + frame_length = 0; > > + list_for_each_entry(t, &m->transfers, transfer_list) > > + frame_length += t->len / (t->bits_per_word >> 3); > > + frame_length = min_t(unsigned int, frame_length, QSPI_FRAME); > > > > This doesn't seem obviously correct - what exactly is the frame length > here and why doesn't it change per transfer like the word length does? > There's nothing in the changelog about this. The frame_length is the number of words in the frame, as it was before this change. Shall I insert a preparatory patch to give the variables better names? Ben. -- Ben Hutchings Software Developer, Codethink Ltd. -- To unsubscribe from this list: send the line "unsubscribe linux-spi" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html