Okash Khawaja, on ven. 28 avril 2017 21:54:48 +0100, wrote: > +static int spk_ttyio_receive_buf2(struct tty_struct *tty, > + const unsigned char *cp, char *fp, int count) > +{ > + struct spk_ldisc_data *ldisc_data = (struct spk_ldisc_data *)tty->disc_data; > +static unsigned char ttyio_in(int timeout) > +{ > + struct spk_ldisc_data *ldisc_data = > + (struct spk_ldisc_data *)speakup_tty->disc_data; No need to make an explicit cast: disc_data is a void*, so the implicit cast is fine and more readable ; only a C++ compiler would complain about it. Apart from that it looks good. So I guess now we need to be more pushy with serdev. Samuel _______________________________________________ Speakup mailing list Speakup@xxxxxxxxxxxxxxxxx http://linux-speakup.org/cgi-bin/mailman/listinfo/speakup