[PATCH v3 05/15] use better names for simplify_mask_or_and() vars

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



So that the names match the ones used in the comments
describing the simplification.

Signed-off-by: Luc Van Oostenryck <luc.vanoostenryck@xxxxxxxxx>
---
 simplify.c | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

diff --git a/simplify.c b/simplify.c
index 9275be430..a7edd2903 100644
--- a/simplify.c
+++ b/simplify.c
@@ -547,10 +547,11 @@ undef:
 }
 
 static int simplify_mask_or_and(struct instruction *insn, unsigned long long mask,
-	pseudo_t src, pseudo_t other)
+	pseudo_t ora, pseudo_t orb)
 {
 	unsigned long long omask, nmask;
-	pseudo_t src2 = src->def->src2;
+	struct instruction *and = ora->def;
+	pseudo_t src2 = and->src2;
 
 	if (!constant(src2))
 		return 0;
@@ -561,7 +562,7 @@ static int simplify_mask_or_and(struct instruction *insn, unsigned long long mas
 	// replace OP(((x & M') | b), K)
 	// by      OP(b, K)
 	// when	(M' & M) == 0
-	return replace_pseudo(insn, &insn->src1, other);
+	return replace_pseudo(insn, &insn->src1, orb);
 }
 
 static int simplify_mask_or(struct instruction *insn, unsigned long long mask, struct instruction *or)
-- 
2.18.0




[Index of Archives]     [Newbies FAQ]     [LKML]     [IETF Annouce]     [DCCP]     [Netdev]     [Networking]     [Security]     [Bugtraq]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux SCSI]     [Trinity Fuzzer Tool]

  Powered by Linux