Re: [PATCH v2 05/15] use better names for simplify_mask_or_and() vars

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 




On 16/08/18 23:12, Luc Van Oostenryck wrote:
> So that the names match the ones used in the comments
> describing the simplification.
> 
> Signed-off-by: Luc Van Oostenryck <luc.vanoostenryck@xxxxxxxxx>
> ---
>  simplify.c | 7 ++++---
>  1 file changed, 4 insertions(+), 3 deletions(-)
> 
> diff --git a/simplify.c b/simplify.c
> index 5d5bd3f00..4c3036963 100644
> --- a/simplify.c
> +++ b/simplify.c
> @@ -547,10 +547,11 @@ undef:
>  }
>  
>  static int simplify_mask_or_and(struct instruction *insn, unsigned long long mask,
> -	pseudo_t src, pseudo_t other)
> +	pseudo_t ora, pseudo_t orb)

I can't say that these names are any better myself! ;-)

Is this supposed to be or_lhs and or_rhs?

ATB,
Ramsay Jones

>  {
>  	unsigned long long omask, nmask;
> -	pseudo_t src2 = src->def->src2;
> +	struct instruction *and = ora->def;
> +	pseudo_t src2 = and->src2;
>  
>  	if (!constant(src2))
>  		return 0;
> @@ -561,7 +562,7 @@ static int simplify_mask_or_and(struct instruction *insn, unsigned long long mas
>  	// replace OP(((A & M') | B), C)
>  	// by      OP(B, C)
>  	// when	(M' & M) == 0
> -	return replace_pseudo(insn, &insn->src1, other);
> +	return replace_pseudo(insn, &insn->src1, orb);
>  }
>  
>  static int simplify_mask_or(struct instruction *insn, unsigned long long mask, struct instruction *or)
> 



[Index of Archives]     [Newbies FAQ]     [LKML]     [IETF Annouce]     [DCCP]     [Netdev]     [Networking]     [Security]     [Bugtraq]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux SCSI]     [Trinity Fuzzer Tool]

  Powered by Linux