This series contains some cleanups of the list walking macros. The main changes are: * use structurally equivalent struct for all pointer lists to avoid needless casting to and fro struct ptrlist * simplify PREPARE/NEXT/RESET logic by using common PTR_NEXT() This series is available for testing & review in the Git repository at: git://github.com/lucvoo/sparse-dev.git ptrlist-cleanup ---------------------------------------------------------------- Luc Van Oostenryck (13): ptrlist: let all pointer lists have the same parametrized structure ptrlist: when possible use the real type of the list ptrlist: remove now unneeded CHECK_TYPE() ptrlist: make add_ptr_list() more readable ptrlist: make free_ptr_list() more readable ptrlist: remove some unneeded arg from internal macros. ptrlist: remove extra ident level ptrlist: simplify loop nesting ptrlist: simplify DO_NEXT ptrlist: simplify PREPARE/NEXT ptrlist: shorter continuated lines ptrlist: remove ptr_list_empty() ptrlist: make {first,last}_ptr_list() out-of-line functions lib.c | 2 +- ptrlist.c | 38 +++++++ ptrlist.h | 321 +++++++++++++++++++++++------------------------------- 3 files changed, 177 insertions(+), 184 deletions(-) -- 2.17.1 -- To unsubscribe from this list: send the line "unsubscribe linux-sparse" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html