On Sat, Dec 10, 2016 at 7:03 AM, Luc Van Oostenryck <luc.vanoostenryck@xxxxxxxxx> wrote: > There is already support for __int128_t & __uint128_t but not yet > for GCC's __int128. > > This patch add support for it and a couple of test cases. > > Note: it's slightly more tricky that it look because contrary to > '__int128_t', '__int128' is not an exact type (it can still receive > the 'unsigned' or 'signed' specifier). > > @@ -1496,6 +1504,8 @@ static struct token *declaration_specifiers(struct token *token, struct decl_sta > } > seen |= s->op->set; > class += s->op->class; > + if (s->op->set & Set_Int128) > + size = 2; > if (s->op->type & KW_SHORT) { > size = -1; > } else if (s->op->type & KW_LONG && size++) { This patch is already applied in sparse-next. But I have a question regarding the "size = 2;" Is the number 2 a magic number? Chris -- To unsubscribe from this list: send the line "unsubscribe linux-sparse" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html