On Fri, Sep 28, 2012 at 06:20:04PM -0500, Daniel Santos wrote: > Throughout compiler*.h, many version checks are made. These can be > simplified by using the macro that gcc's documentation recommends. > However, my primary reason for adding this is that I need bug-check > macros that are enabled at certain gcc versions and it's cleaner to use > this macro than the tradition method: > > if __GNUC__ > 4 || (__GNUC__ == 4 && __GNUC_MINOR__ => 2) > > If you add patch level, it gets this ugly: > > if __GNUC__ > 4 || (__GNUC__ == 4 && (__GNUC_MINOR__ > 2 || \ > __GNUC_MINOR__ == 2 __GNUC_PATCHLEVEL__ >= 1)) > > As opposed to: > > if GCC_VERSION >= 40201 > > While having separate headers for gcc 3 & 4 eliminates some of this > verbosity, they can still be cleaned up by this. Yes, very fine readability improvement. Acked-by: Borislav Petkov <bp@xxxxxxxxx> -- Regards/Gruss, Boris. -- To unsubscribe from this list: send the line "unsubscribe linux-sparse" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html