Thanks for the review,
On 01/03/18 21:28, Mark Brown wrote:
On Tue, Feb 13, 2018 at 04:58:22PM +0000, srinivas.kandagatla@xxxxxxxxxx wrote:
+ num_regions = is_contiguous ? 1 : periods;
+ buf_sz = is_contiguous ? (period_sz * periods) : period_sz;
Please write normal if statements, it's much easier to read.
Sure, will fix it in next version.
+ buf_sz = PAGE_ALIGN(buf_sz);
I don't understand what this is doing, buf_sz is a length not an address
so why are we attempting to align it?
Yes, this is a requirement form the DSP side that the size is multiple
of 4KB. I will fix this properly in next version.
thanks,
srini
--
To unsubscribe from this list: send the line "unsubscribe linux-soc" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html