On Fri, Sep 15, 2023 at 07:55:45AM -1000, Tejun Heo wrote: > On Tue, Sep 12, 2023 at 09:06:18PM -0700, Haitao Huang wrote: > > @@ -37,6 +37,11 @@ struct misc_res { > > u64 max; > > atomic64_t usage; > > atomic64_t events; > > + > > + /* per resource callback ops */ > > + int (*misc_cg_alloc)(struct misc_cg *cg); > > + void (*misc_cg_free)(struct misc_cg *cg); > > + void (*misc_cg_max_write)(struct misc_cg *cg); > > A nit about naming. These are already in misc_res and cgroup_ and cgrp_ > prefixes are a lot more common. So, maybe go for sth like cgrp_alloc? Ah, never mind about the prefix part. misc is using cg_ prefix widely already. Thanks. -- tejun