On Mon, Aug 17, 2020 at 09:24:05PM -0700, Sean Christopherson wrote: > Allow userspace to exit the vDSO on interrupts that are acknowledged > while the enclave is active. This allows the user's runtime to switch > contexts at opportune times without additional overhead, e.g. when using > an M:N threading model (where M user threads run N TCSs, with N > M). > > Suggested-by: Jethro Beekman <jethro@xxxxxxxxxxxx> > Signed-off-by: Sean Christopherson <sean.j.christopherson@xxxxxxxxx> > --- > arch/x86/entry/vdso/vsgx_enter_enclave.S | 27 ++++++++++++++++++++---- > arch/x86/include/uapi/asm/sgx.h | 3 +++ > 2 files changed, 26 insertions(+), 4 deletions(-) > > diff --git a/arch/x86/entry/vdso/vsgx_enter_enclave.S b/arch/x86/entry/vdso/vsgx_enter_enclave.S > index b09e87dbe9334..33428c0f94b0d 100644 > --- a/arch/x86/entry/vdso/vsgx_enter_enclave.S > +++ b/arch/x86/entry/vdso/vsgx_enter_enclave.S > @@ -21,6 +21,9 @@ > > #define SGX_SYNCHRONOUS_EXIT 0 > #define SGX_EXCEPTION_EXIT 1 > +#define SGX_INTERRUPT_EXIT 2 > + > +#define SGX_EXIT_ON_INTERRUPTS 1 This naming scheme does not look too great. I have nothing principal about code changes, *if* this is the approach where we want to move. I did not look every detail because I'm not sure what is the consensus yet. /Jarkko