On 7/8/2019 4:53 PM, Casey Schaufler wrote:
On 7/8/2019 10:16 AM, Xing, Cedric wrote:
On 7/8/2019 9:26 AM, Casey Schaufler wrote:
In this scheme you use an ema LSM to manage your ema data.
A quick sketch looks like:
sgx_something_in() calls
security_enclave_load() calls
ema_enclave_load()
selinux_enclave_load()
otherlsm_enclave_load()
Why is this better than:
sgx_something_in() calls
ema_enclave_load()
security_enclave_load() calls
selinux_enclave_load()
otherlsm_enclave_load()
Are you talking about moving EMA somewhere outside LSM?
Yes. That's what I've been saying all along.
If so, where?
I tried to make it obvious. Put the call to your EMA code
on the line before you call security_enclave_load().
Sorry but I'm still confused.
EMA code is used by LSMs only. Making it callable from other parts of
the kernel IMHO is probably not a good idea. And more importantly I
don't understand the motivation behind it. Would you please elaborate?
+/**
+ * ema - Enclave Memory Area structure for LSM modules
LSM modules is redundant. "LSM" or "LSMs" would be better.
Noted
diff --git a/security/Makefile b/security/Makefile
index c598b904938f..b66d03a94853 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -28,6 +28,7 @@ obj-$(CONFIG_SECURITY_YAMA) += yama/
obj-$(CONFIG_SECURITY_LOADPIN) += loadpin/
obj-$(CONFIG_SECURITY_SAFESETID) += safesetid/
obj-$(CONFIG_CGROUP_DEVICE) += device_cgroup.o
+obj-$(CONFIG_INTEL_SGX) += commonema.o
The config option and the file name ought to match,
or at least be closer.
Just trying to match file names as "capability" uses commoncap.c.
Fine, then you should be using CONFIG_SECURITY_EMA.
Like I said, this feature could potentially be used by TEEs other than SGX. For now, SGX is the only user so it is tied to CONFIG_INTEL_SGX. I can rename it to ema.c or enclave.c. Do you have a preference?
Make
CONFIG_SECURITY_EMA
depends on CONFIG_INTEL_SGX
When another TEE (maybe MIPS_SSRPQ) comes along you can have
CONFIG_SECURITY_EMA
depends on CONFIG_INTEL_SGX || CONFIG_MIPS_SSRPQ
Your suggestions are reasonable. Given such config change wouldn't
affect any code, can we do it later, e.g., when additional TEEs come
online and make use of these new hooks? After all,
security_enclave_init() will need amendment anyway as one of its current
parameters is of type 'struct sgx_sigstruct', which will need to be
replaced with something more generic. At the time being, I'd like to
keep things intuitive so as not to confuse reviewers.
diff --git a/security/commonema.c b/security/commonema.c
Put this in a subdirectory. Please.
Then why is commoncap.c located in this directory? I'm just trying to match the existing convention.
commoncap is not optional. It is a base part of the
security subsystem. ema is optional.
Alright. I'd move it into a sub-folder and rename it to ema.c. Would you
be ok with that?