On Sat, May 02, 2015 at 03:44:42PM +0800, Jun Nie wrote: > 2015-05-01 5:55 GMT+08:00 Russell King - ARM Linux <linux@xxxxxxxxxxxxxxxx>: > > On Wed, Apr 29, 2015 at 09:38:37AM +0800, Jun Nie wrote: > >> diff --git a/drivers/tty/serial/amba-pl011.c b/drivers/tty/serial/amba-pl011.c > >> index 14941be..6db5ee4 100644 > >> --- a/drivers/tty/serial/amba-pl011.c > >> +++ b/drivers/tty/serial/amba-pl011.c > >> @@ -75,6 +75,10 @@ > >> /* There is by now at least one vendor with differing details, so handle it */ > >> struct vendor_data { > >> unsigned int ifls; > >> + unsigned int fr_busy; > >> + unsigned int fr_dsr; > >> + unsigned int fr_cts; > >> + unsigned int u1_fr_ri; > > > > Why does the ringing indicator entry have a 'u1_' prefix on it? > > > To note it is uart011 register because other name is uart01x. I can > use fr_ri if you agree. In amba/serial.h, the naming convention is: UART01x_* definitions shared between PL010 and PL011 UART010_* definitions only for PL010 UART011_* definitions only for PL011 ST_UART011_* definitions only for STMicro's PL011 There is no need to carry the PL010/PL011 differences into the PL011 driver because it's never going to have PL010 support merged into this driver. -- FTTC broadband for 0.8mile line: currently at 10.5Mbps down 400kbps up according to speedtest.net. -- To unsubscribe from this list: send the line "unsubscribe linux-serial" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html