On Sunday 14 October 2012, Alexander Shiyan wrote: > + > +static int __init uart_clps711x_init(void) > +{ > + return platform_device_register(&clps711x_uart_device); > +} > +module_init(uart_clps711x_init); > + > +static void __exit uart_clps711x_exit(void) > +{ > + platform_device_unregister(&clps711x_uart_device); > +} > +module_exit(uart_clps711x_exit); Patch looks good in general, but the above could be simplified to use module_platform_driver(); Arnd -- To unsubscribe from this list: send the line "unsubscribe linux-serial" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html