On Mon, 6 Sep 2010 22:15:42 +0800 Alan Cox <alan@xxxxxxxxxxxxxxx> wrote: > > > > + /* GPIO workaround */ > > > + set_fixmap_nocache(FIX_EARLYCON_MEM_BASE, > > > MFD_GPIO_HSU_REG); > > > + phsu = (void *)(__fix_to_virt(FIX_EARLYCON_MEM_BASE) + > > > + (MFD_GPIO_HSU_REG & (PAGE_SIZE - 1))); > > > + > > > + *((u32 *)phsu) = 0x55465; > > > > What does 0x55465 stand for? > > It's a firmware fixup. Its a magic value (even to most of us who work > here ;)). Feng - am I right in thinking we don't need that anyway with > the current firmware ? Yes, it's a fixup for firmware, it set GPIO controller's register to correctly configure the GPIO lines used by HSU. Latest firmware already fix that, and it could be removed. Thank you both for the comments, will try to address them and make a v2. Thanks, Feng -- To unsubscribe from this list: send the line "unsubscribe linux-serial" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html