Kees Cook wrote: > >> - seq_printf(seq, "%*s\n", 127 - len, ""); > >> + seq_pad(seq, '\n'); > > > > Hmm, seq_pad is unintuitive. I would say it pads the string by '\n'. Of > > course it does not, but... > > I don't think this is a very serious problem. Currently, the padding > character is always ' ' for all existing callers, so it only makes > sense to make the trailing character an argument. If you want, we can rename seq_pad() to seq_pad_and_putc(). Also we can pass both the padding character (e.g. ' ') and the trailing character (e.g. '\n') like seq_pad_and_putc((' ' << 8) | '\n'), though I wonder someone wants to use '\0', '\t', '\n' etc. as the padding character... -- To unsubscribe from this list: send the line "unsubscribe linux-sctp" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html