The "goto try_again" statement is executed at most once. Since the above loop can be unfolded with only a very minor code duplication I think it should be unfolded, e.g. as follows: se_acl = core_tpg_get_initiator_node_acl(&sport->port_tpg_1, ch->sess_name); if (!se_acl) se_acl = core_tpg_get_initiator_node_acl(&sport->port_tpg_1, ch->sess_name + strlen("0x")); if (!se_acl) { pr_info("Rejected login because no ACL has been" " configured yet for initiator %s.\n", ch->sess_name); [ ... ] }
I tend to agree, and it would be a bit cleaner to hide this behind srpt_get_initiator_node_acl wrapper. -- To unsubscribe from this list: send the line "unsubscribe linux-scsi" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html