On 10/30/2015 11:49 AM, Gabriel Krisman Bertazi wrote:
if (ipr_is_gscsi(res) || ipr_is_vset_device(res)) { - if (scsi_cmd->underflow == 0) + if (scsi_cmd->underflow == 0 && !ipr_is_vset_device(res))
This section is getting quite convoluted. If there isn't really that much common between ipr_is_gscsi(res) and ipr_is_vset_device(res) anymore, it would read much better as distinct segments: if (ipr_is_gscsi(res)) ... if (ipr_is_vset_devices(res)) ... This will avoid having multiple calls to ipr_is_gscsi() and ipr_is_vset_device() in the same section of code. --- Manoj Kumar -- To unsubscribe from this list: send the line "unsubscribe linux-scsi" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html