CONFIG_ACORNSCSI_CONSTANTS is a file local CPP identifier and thereby violates the naming convention of Kconfig options in Make and CPP syntax; only Kconfig options should carry the 'CONFIG_' prefix. This patch removes the 'CONFIG_' prefix to apply to this convention and to make static analysis tools happy. Signed-off-by: Valentin Rothberg <valentinrothberg@xxxxxxxxx> --- I detected this issue with ./scripts/checkkconfigsymbols.py --- drivers/scsi/arm/acornscsi.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/scsi/arm/acornscsi.c b/drivers/scsi/arm/acornscsi.c index deaaf84989cd..ce764c3ed99c 100644 --- a/drivers/scsi/arm/acornscsi.c +++ b/drivers/scsi/arm/acornscsi.c @@ -96,7 +96,7 @@ * Define this if you want to have verbose explanation of SCSI * status/messages. */ -#undef CONFIG_ACORNSCSI_CONSTANTS +#undef ACORNSCSI_CONSTANTS /* * Define this if you want to use the on board DMAC [don't remove this option] * If not set, then use PIO mode (not currently supported). @@ -399,7 +399,7 @@ void acornscsi_resetcard(AS_Host *host) /*============================================================================================= * Utility routines (eg. debug) */ -#ifdef CONFIG_ACORNSCSI_CONSTANTS +#ifdef ACORNSCSI_CONSTANTS static char *acornscsi_interrupttype[] = { "rst", "suc", "p/a", "3", "term", "5", "6", "7", @@ -477,7 +477,7 @@ void print_scsi_status(unsigned int ssr) static void print_sbic_status(int asr, int ssr, int cmdphase) { -#ifdef CONFIG_ACORNSCSI_CONSTANTS +#ifdef ACORNSCSI_CONSTANTS printk("sbic: %c%c%c%c%c%c ", asr & ASR_INT ? 'I' : 'i', asr & ASR_LCI ? 'L' : 'l', -- 2.1.4 -- To unsubscribe from this list: send the line "unsubscribe linux-scsi" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html