On Tue 14 Apr 05:11 PDT 2015, Akinobu Mita wrote: > 2015-02-12 12:35 GMT+09:00 Bjorn Andersson <bjorn.andersson@xxxxxxxxxxxxxx>: > > The function regulator_set_optimum_mode() is changing name to > > regulator_set_load(), so update the code accordingly. Also cleaned up > > ufshcd_config_vreg_load() while touching the code. > > > > Signed-off-by: Bjorn Andersson <bjorn.andersson@xxxxxxxxxxxxxx> [..] > > static inline int ufshcd_config_vreg_hpm(struct ufs_hba *hba, > > struct ufs_vreg *vreg) > > { > > - if (!vreg) > > - return 0; > > - > > return ufshcd_config_vreg_load(hba->dev, vreg, vreg->max_uA); > > } > > I tried this patch and it caused kernel null pointer dereference with > 'verg->max_uA' when vreg == NULL. So you can't simply move !vreg check here > into ufshcd_config_vreg_load(). Akinobu-san, you're correct, sorry for missing that (and in essence reverting your commit). Looks like Linus merged the fix on master, so I will send out a fixup. Regards, Bjorn -- To unsubscribe from this list: send the line "unsubscribe linux-scsi" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html