On Wednesday 25 February 2015 07:41:36 Tina Ruchandani wrote: > @@ -364,10 +365,7 @@ MODULE_VERSION(ST_DRIVER_VERSION); > > static void stex_gettime(__le64 *time) > { > - struct timeval tv; > - > - do_gettimeofday(&tv); > - *time = cpu_to_le64(tv.tv_sec); > + *time = cpu_to_le64(ktime_get_real_seconds()); > } > > static struct status_msg *stex_get_status(struct st_hba *hba) > The patch looks correct to me, but upon second reading, I think it would be nicer to eliminate the function entirely and open-code the cpu_to_le64(ktime_get_real_seconds()) in the two callers. Arnd -- To unsubscribe from this list: send the line "unsubscribe linux-scsi" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html