On 04/03/2014 11:01 AM, Christoph Hellwig wrote: > On Thu, Apr 03, 2014 at 09:45:11AM -0700, Matias Bjorling wrote: >>> I'd still create a request_queue for the internal queue, just not register >>> a block device for it. For example SCSI sets up queues for each LUN >>> found, but only a subset actually is exposed as a block device. >>> >> >> Ok. That is good enough for now. A little heavy on the overhead side, if >> only the tag logic is needed. >> >> What about the following suggestions for shared tags: >> >> 1. Rename it from blk_mq_shared_tags to blk_mq_tag_group. A driver can >> have several tag groups that it maintains. > > I was going to rename it to tag_set, but tag_group sounds fine to me as well. > tag_set is shorter. tag_set it is. >> 2. Instead of blk_mq_shared_tags structure in blk_mq_reg. Have function >> pointer for getting the tags structure during hctx initialization. This >> is interesting for nvme, because it has as set of tags for each hardware >> queue it exposes. > > The current code also has an array of blk_mq_tags structures, one for > each queue. Do you need a more complicated mapping than that? > No, that's great. Had misinterpreted the arrays, now that I look at it again. Thanks > Btw, I was also going to siply split out the tag allocation from the > queue registration unconditionally. While this adds a little more > boilerplate to simple drivers it avoids unconditional code pathes and should > make the model much easier to understand. I should have a new version > of the patches soon. > ack, good idea. -- To unsubscribe from this list: send the line "unsubscribe linux-scsi" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html