Hello, On Wed, Mar 05, 2014 at 12:17:30PM -0800, Dan Williams wrote: > +#define ata_port_resume_sync(ap, msg) ata_port_resume_common((ap), (msg), false) > +#define queue_ata_port_resume(ap, msg) ata_port_resume_common((ap), (msg), true) Let's please use proper static functions. The compiler can deal with inlining. Also, maybe ata_port_resume() and ata_port_resume_async() are better names for the wrappers? Other than that, libata part looks good to me. Thanks. -- tejun -- To unsubscribe from this list: send the line "unsubscribe linux-scsi" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html