On Thu, Mar 06, 2014 at 02:15:28PM -0800, Andy Grover wrote: > +void core_dev_del_lun( > struct se_portal_group *tpg, > + struct se_lun *lun) > { > + pr_debug("%s_TPG[%u]_LUN[%u] - Deactivating %s Logical Unit from" > " device object\n", tpg->se_tpg_tfo->get_fabric_name(), > + tpg->se_tpg_tfo->tpg_get_tag(tpg), lun->unpacked_lun, > tpg->se_tpg_tfo->get_fabric_name()); > > + core_tpg_post_dellun(tpg, lun); Seems like core_tpg_post_dellun should be folded into core_dev_del_lun? Also would be nice to get some sane names for all the functions in this area.. -- To unsubscribe from this list: send the line "unsubscribe linux-scsi" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html