On Fri, 7 June 2013 21:34:16 +0000, Nicholas A. Bellinger wrote: > > -static int transport_cmd_check_stop(struct se_cmd *cmd, bool remove_from_lists) > +static int transport_cmd_check_stop(struct se_cmd *cmd, bool remove_from_lists, > + bool write_pending) ... > - return transport_cmd_check_stop(cmd, true); > + return transport_cmd_check_stop(cmd, true, false); At this point I would prefer to pass in a flags. transport_cmd_check_stop(cmd, SC_REMOVE_FROM_LISTS) seems more readable to me. The rest of the patchset I rather like. Well done. Jörn -- When you close your hand, you own nothing. When you open it up, you own the whole world. -- Li Mu Bai in Tiger & Dragon -- To unsubscribe from this list: send the line "unsubscribe linux-scsi" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html