> Hi, > > I have several places in my code where the new __must_check of strstrip > will introduce unnecessary dummy variables to avoid the warnings. > > Therefore I would like to have the suggested new strim() or > strstip_tail() function. Any chance to have this upstream soon? strim() is in mmotm now. I expect it will merge mainline soon. Thanks. > > Michael > > On Wed, 2009-11-04 at 04:58 +0900, KOSAKI Motohiro wrote: > > 2009/11/4 Alan Cox <alan@xxxxxxxxxxxxxxxxxxx>: > > >> static inline void strsrip_tail(char *str) > > >> { > > >> char *x __used; > > >> x = strstrip(str); > > >> } > > > > > > Bikeshed time but its cleaner to do > > > > > > static inline __must_check void strstrip(char *str) > > > { > > > return strim(str); > > > } > > > > > > and make strim() the old strstrip function without the check requirement > > > > Okey... > > > > [quick hack and compile check] > > > > done :) > > sorry for attached file. I'm under poor mail environment now. > -- To unsubscribe from this list: send the line "unsubscribe linux-scsi" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html