I agree with Sergey's comments. In addition: On Fri, May 01, 2009 at 07:25:51PM -0700, David VomLehn wrote: > +initdev_wait(enum initdev_type type, bool (*done)(void)) > + Wait until one of two conditions is met: > + o All possible init devices of the given type have been probed > + o The "done" function returns true > + > + The type is one of: > + BOOTDEV_CONSOLE > + BOOTDEV_NETDEV > + BOOTDEV_BLOCK These should be named INITDEV_CONSOLE_TYPE and so on, with the final _TYPE suffix to help prevent confusion with INITDEV_CONSOLE_MASK. Also, in patch 3/5: > --- a/drivers/accessibility/braille/braille_console.c > +++ b/drivers/accessibility/braille/braille_console.c > @@ -35,6 +35,7 @@ > #include <linux/keyboard.h> > #include <linux/kbd_kern.h> > #include <linux/input.h> > +#include <linux/initdev.h> What does this do? It looks like a typo. Alan Stern -- To unsubscribe from this list: send the line "unsubscribe linux-scsi" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html