Re: [PATCH] Restart scsi_device_lookup_by_target

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi Matthew,

Hannes Reinecke wrote:
Matthew Wilcox wrote:
On Tue, Jan 13, 2009 at 02:50:30PM +0100, Hannes Reinecke wrote:
@@ -1131,14 +1137,15 @@ EXPORT_SYMBOL(__scsi_device_lookup_by_target);
struct scsi_device *scsi_device_lookup_by_target(struct scsi_target *starget,
                          uint lun)
 {
-    struct scsi_device *sdev;
+    struct scsi_device *sdev = NULL;
     struct Scsi_Host *shost = dev_to_shost(starget->dev.parent);
     unsigned long flags;
spin_lock_irqsave(shost->host_lock, flags);
-    sdev = __scsi_device_lookup_by_target(starget, lun);
+ restart:
+    sdev = __scsi_device_lookup_by_target(starget, sdev, lun);
     if (sdev && scsi_device_get(sdev))
-        sdev = NULL;
+        goto restart;
     spin_unlock_irqrestore(shost->host_lock, flags);
return sdev;

Backwards jumps are generally disapproved of.  How about:

    spin_lock_irqsave(shost->host_lock, flags);
    for (;;) {
        sdev = __scsi_device_lookup_by_target(starget, sdev, lun);
        if (!sdev || !scsi_device_get(sdev))
            break;
    }
    spin_unlock_irqrestore(shost->host_lock, flags);


I must say I don't really like the for(;;) construct.
And it's really confusing as we want to find an sdev, so breaking
if it's _not_ found is ... weird.

What about

	do {
		sdev = __scsi_device_lookup_by_target(starget, sdev, lun);
	} while (sdev && scsi_device_get(sdev));

?
Should be identical and easier to read ...

Cheers,

Hannes
--
Dr. Hannes Reinecke		      zSeries & Storage
hare@xxxxxxx			      +49 911 74053 688
SUSE LINUX Products GmbH, Maxfeldstr. 5, 90409 Nürnberg
GF: Markus Rex, HRB 16746 (AG Nürnberg)
--
To unsubscribe from this list: send the line "unsubscribe linux-scsi" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[Index of Archives]     [SCSI Target Devel]     [Linux SCSI Target Infrastructure]     [Kernel Newbies]     [IDE]     [Security]     [Git]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux ATA RAID]     [Linux IIO]     [Samba]     [Device Mapper]
  Powered by Linux