Re: [PATCH 4/8] scsi: ufs: qcom: Implement the freq_to_gear_speed() vops

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 





On 1/20/2025 11:41 PM, Manivannan Sadhasivam wrote:
On Mon, Jan 20, 2025 at 08:07:07PM +0800, Ziqi Chen wrote:
Hi Mani,

Thanks for your comments~

On 1/19/2025 3:30 PM, Manivannan Sadhasivam wrote:
On Thu, Jan 16, 2025 at 05:11:45PM +0800, Ziqi Chen wrote:
From: Can Guo <quic_cang@xxxxxxxxxxx>

Implement the freq_to_gear_speed() vops to map the unipro core clock
frequency to the corresponding maximum supported gear speed.

Co-developed-by: Ziqi Chen <quic_ziqichen@xxxxxxxxxxx>
Signed-off-by: Ziqi Chen <quic_ziqichen@xxxxxxxxxxx>
Signed-off-by: Can Guo <quic_cang@xxxxxxxxxxx>
---
   drivers/ufs/host/ufs-qcom.c | 32 ++++++++++++++++++++++++++++++++
   1 file changed, 32 insertions(+)

diff --git a/drivers/ufs/host/ufs-qcom.c b/drivers/ufs/host/ufs-qcom.c
index 1e8a23eb8c13..64263fa884f5 100644
--- a/drivers/ufs/host/ufs-qcom.c
+++ b/drivers/ufs/host/ufs-qcom.c
@@ -1803,6 +1803,37 @@ static int ufs_qcom_config_esi(struct ufs_hba *hba)
   	return ret;
   }
+static int ufs_qcom_freq_to_gear_speed(struct ufs_hba *hba, unsigned long freq, u32 *gear)
+{
+	int ret = 0 >
Please do not initialize ret with 0. Return the actual value directly.


If we don't initialize ret here, for the cases of freq matched in the table,
it will return an unknown ret value. It is not make sense, right?

Or you may want to say we don't need “ret” , just need to return gear value?
But we need this "ret" to check whether the freq is invalid.


I meant to say that you can just return 0 directly in success case and -EINVAL
in the case of error.

Hi Mani,

If we don't print freq here , I think your suggestion is very good. If we print freq in this function , using "ret" to indicate success case and failure case and print freq an the end of this function is the way to avoid code bloat.

How do you think about it?

+
+	switch (freq) {
+	case 403000000:
+		*gear = UFS_HS_G5;
+		break;
+	case 300000000:
+		*gear = UFS_HS_G4;
+		break;
+	case 201500000:
+		*gear = UFS_HS_G3;
+		break;
+	case 150000000:
+	case 100000000:
+		*gear = UFS_HS_G2;
+		break;
+	case 75000000:
+	case 37500000:
+		*gear = UFS_HS_G1;
+		break;
+	default:
+		ret = -EINVAL;
+		dev_err(hba->dev, "Unsupported clock freq\n");

Print the freq.

Ok, thank for your suggestion, we can print freq with dev_dbg() in next
version.


No, use dev_err() with the freq. >
- Mani

I think use dev_err() here does not make sense:

1. This print is not an error message , just an information print. Using dev_err() reduces the readability of this code. 2. This prints will be print very frequent, I afraid it will increase the latency of clock scaling.


How do you think ?

-Ziqi






[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[Index of Archives]     [SCSI Target Devel]     [Linux SCSI Target Infrastructure]     [Kernel Newbies]     [IDE]     [Security]     [Git]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux ATA RAID]     [Linux IIO]     [Samba]     [Device Mapper]

  Powered by Linux