On Mon, Nov 04, 2024 at 07:59:00AM -0800, Darrick J. Wong wrote: > Hmm. Looking at your git branch (which was quite helpful to link to!) I > think for XFS we don't need to change the crc32c() calls, and the only > porting work that needs to be done is mirroring this Kconfig change? > And that doesn't even need to be done until someone wants to get rid of > CONFIG_LIBCRC32C, right? That's correct, no porting work is required now. 'select LIBCRC32C' should be replaced with 'select CRC32', but that can be done later. > > @@ -3278,15 +3263,11 @@ extern void ext4_group_desc_csum_set(struct super_block *sb, __u32 group, > > extern int ext4_register_li_request(struct super_block *sb, > > ext4_group_t first_not_zeroed); > > > > static inline int ext4_has_metadata_csum(struct super_block *sb) > > { > > - WARN_ON_ONCE(ext4_has_feature_metadata_csum(sb) && > > - !EXT4_SB(sb)->s_chksum_driver); > > - > > - return ext4_has_feature_metadata_csum(sb) && > > - (EXT4_SB(sb)->s_chksum_driver != NULL); > > + return ext4_has_feature_metadata_csum(sb); > > } > > Nit: Someone might want to > s/ext4_has_metadata_csum/ext4_has_feature_metadata_csum/ here to get rid > of the confusingly named trivial helper. > Yes, that should be done as a follow-up patch. > Otherwise this logic looks ok to me, so > Reviewed-by: Darrick J. Wong <djwong@xxxxxxxxxx> > > --D Thanks, - Eric